Hardware Requirements


COMPUTER & OPERATING SYSTEM

WindowsLinux x86Linux ARMv7Linux ARMv8
ProcessorIntel i5 or betterIntel i5 or betterARMv7 (32-bit)ARMv8 (64-bit)
Memory4 GB recommended4GB recommended2 GB2 GB
Hard Drive Space150 MB
150 MB
50 MB
50 MB

   


Laptop Computers


Because of the specialized hardware configurations of laptop computers, they may require additional installation considerations:

 

  • A graphics card with at least 64 MB of video memory. – Most new laptops aimed at gaming, video/DVD display or multi-media should be adequate.

  • For FireWire cameras:

    • A built-in interface port, or a preinstalled CardBus card slot and a interface CardBus adapter card (as appropriate for the camera model).  

    • An external 12 V DC power supply – Although certain laptop models may be able to provide power to the camera via the FireWire bus, it is more likely that the system will require an external power supply for the camera. (Note:  A four-pin FireWire connector cannot provide power to the camera, nor can a CardBus adapter card provide sufficient power).


Operating System


Microsoft Windows


Microsoft Windows VersionFireWire CamerasGigE CamerasUSB 2.0 CamerasUSB 3.0 Cameras  
Windows 10SupportedSupportedSupportedSupported
Windows 8, 32-bit or 64-bitSupportedSupportedSupportedSupported
Windows 7, 32-bit or 64-bitSupportedSupportedSupportedSupported
Windows Vista Not SupportedNot SupportedNot SupportedNot Supported
Windows XPNot SupportedNot SupportedNot SupportedNot Supported
Windows 2000Not SupportedNot SupportedNot SupportedNot Supported


Service Packs are available for download from the Microsoft Web Site, http://www.microsoft.com/


** Please note, our Capture BE software for our PL-S621 camera is only compatible up to Windows XP



Linux


 Linux Version FireWire GigEUSB2.0 
 USB3.0
PC running Ubuntu
v14.04, v16.04, v18.04, 64-bit
Not SupportedNot SupportedNot SupportedSupported
ARMv7 platform running Ubuntu
 v14.04, v16.04, 32-bit
Not SupportedNot Supported
Not SupportedSupported
ARMv8 platform running Ubuntu,
v14.04, v16.04,  64-bit
Not SupportedNot SupportedNot SupportedSupported



Macintosh


PixeLINK does not provide support for Mac OS X.